Slecht nieuws voor Battlefield 2 spelers. Dice heeft de vierde patch voor de game tot nader order uitgesteld. Volgens Dice hebben ze een stabiliteitsprobleem ontdekt dat zo snel mogelijk opgelost moest worden.

De patch 1.4 is echter wel uitgelekt op het web. De makers hebben er sterk op aan gedrongen om deze niet te installeren.
"It has come to our attention that a beta version of the 1.4 client has leaked to the general public. It should be noted by players that this file is not final and being such could cause damage to players systems", aldus Dice in een verklaring

Volgens de spelers is patch 1.4 een sterke verbetering ten opzichte van patch 1.3 waar het heel erg misging. Patch 1.3 introduceerde crashes naar de desktop, rode/blauwe tag verandering en exploits waardoor valsspelers niet konden doodgaan. Deze problemen zijn nu misschien verholpen