Android-toestellen met Qualcomm-chips gevoelig voor hack

Abonneer je gratis op Techzine!

Een beveiligingsbedrijf heeft vier kritieke lekken gevonden in de driver die wordt gebruikt voor Qualcomm-chips op Android-toestellen. Via deze kritieke lekken is het mogelijk volledige toegang te krijgen tot het apparaat. Inmiddels zouden drie van de vier lekken zijn gepatched, met het laatste lek zou Qualcomm meer moeite hebben. Door het kritieke lek lopen honderden miljoenen Android-toestellen wel risico.

Het gaat om beveiligingsbedrijf Checkpoint dat de kwetsbaarheden heeft gepresenteerd tijdens de Def Con-conferentie in Las Vegas. Zij hebben de vier kwetsbaarheden gedoopt tot QuadRooter en hebben ook een app uitgebracht waarmee gebruiker kunnen controleren of hun toestel gevoelig is voor de lekken.

Kwaadwillenden zouden een app kunnen ontwikkelen die misbruik maakt van de lekken en hierdoor de app volledige toegang tot het apparaat kunnen geven, waarmee vervolgens de controle in handen van kwaadwillenden komt te liggen. Zo kan er data worden buitgemaakt, maar kan een toestel ook worden misbruikt voor andere criminele doeleinden.

De vier lekken zitten in de ashmem, ipc_router, kgsl en kgsl_sync. In de laatste Andorid beveiligingsupdates van 1 augustus zijn drie van de vier lekken gedicht. Hierdoor zijn de Nexus-toestellen al niet meer gevoelig voor deze lekken, andere toestellen worden hopelijk snel voorzien van een update. Checkpoint heeft de vier lekken in april al aan Qualcomm gepresenteerd, zodat het bedrijf patches kon ontwikkelen. Google zal in september ook het laatste lek gaan dichten met een beveiligingsupdate.

Wanneer de meeste toestellen gepatched zijn voor deze lekken is moeilijk te voorspellen, maar waarschijnlijk duurt dat nog wel even. Google brengt elke maand beveiligingsupdates uit, maar de fabrikanten van de toestellen moeten deze geschikt maken en verspreiden naar hun toestellen, iets wat maar mondjesmaat gebeurd.