min

Tags in dit artikel

, ,

Vrijdag was de release van Apple’s nieuwste besturingssysteem Mac OS 10.5 Leopard. Nu al is er een groot probleem ontdekt bij het gebruik ervan. Leopard is namelijk niet compatibel met de nieuwe versie van Java.

Het gaat hier om versie 1.6 van Java. Als gevolg hiervan zijn Java-ontwikkelaars verplicht te werken met het oudere Mac OS X 10.4 Tiger omdat deze de nieuwste Java versie wel ondersteund. De oorzaak van het probleem kan gevonden worden in de Java Virtual Machine. Hier wordt de Java-code omgezet naar ‘computer’-code.

Normaal maakt Sun, ontwikkelaar van Java, de Virtual Machine. Apple heeft echter deze keer zelf de Virtual Machine ontwikkeld. Daar is dus iets bij fout gegaan waardoor sommige Java-applicaties niet goed draaien op Leopard.

Apple heeft nog geen reactie gegeven en dus is het nog onduidelijk wanneer er actie ondernomen wordt. Tot die tijd zal men, indien nodig, gebruik moeten maken van Mac OS X 10.4 Tiger.