‘Google eist KitKat op alle nieuwe Androids’

Abonneer je gratis op Techzine!

Om het fragmentatieprobleem van Android zo gauw mogelijk tot een einde te brengen, zou Google van fabrikanten eisen dat er vanaf heden bij nieuwe producten alleen gebruik wordt gemaakt van de nieuwste versie van het besturingssysteem. Dat blijkt uit een memo van Google, die Mobile Bloom in handen kreeg.

Op het gebied van veiligheid en compatibiliteit heeft het mobiele besturingssysteem Android nog aardige stappen te maken. Dat bleek ook begin deze maand weer, toen Google bekendmaakte dat pas 1,8 procent van alle apparaten op Android 4.4 KitKat (review) draait. Bij concurrent Apple zit zo’n 80 procent op de meest recente versie van het besturingssysteem iOS.

Als fabrikanten willen dat hun nieuwe Android-apparaten de Google Play Store en apps zoals Gmail en YouTube kunnen gebruiken, dan moeten ze sinds deze maand de nieuwste versie van Android erop plaatsen. Google zal toestellen met een oudere versie niet langer goedkeuren. Dat blijkt uit een memo van Google, het is onduidelijk naar welke fabrikant deze verstuurd is.

Android 4.4 KitKat werd speciaal ontwikkeld met goedkopere apparaten in het achterhoofd. Waar bij voorgaande releases de hardware-eisen almaar hoger kwamen te liggen, gingen deze bij KitKat juist omlaag. Dat betekent dat vrijwel elk nieuw Android-apparaat het besturingssysteem goed zal kunnen draaien.